YAML Language Codes

I get error "We expected you to upload file with language code XX. Please check that you uploaded a correct file". Why?

Have more questions? Submit a request

1 Comments

  • 0
    Avatar
    Get Localization

    Ruby on Rails files root element is always the language code, therefore we require that when you upload language files, they have also correct language code as a root element. 

    So if your YAML is 

    en:
      hello_world: Hello the world
    

     

    Make sure that your translated files contain the correct language code:

    E.g. if you are uploading Finnish translations, you should have 'fi' as a root element:

     

    fi:
      hello_world: Terve Maailma
    

     

    Get Localization takes care that all your downloaded translation files have correct language code in place. This is required only if you upload translation files that are made elsewhere. 

Article is closed for comments.
Powered by Zendesk